Rhino C++ API  8.6
Static Public Attributes | List of all members
RhRdk::CustomRenderMeshes::IManager::Flags Struct Reference

Flags to be passed into and returned from RenderMeshes and HasCustomRenderMeshes.
More...

#include <IRhRdkCustomRenderMeshes.h>

Static Public Attributes

static const ON__UINT32 Canceled = 1
 If this flag is set when returned, then CustomMeshes was canceled. More...
 
static const ON__UINT32 DisableCaching = 2
 Pass in this flag to bypass any primitive caching that the MeshProviders might do. More...
 
static const ON__UINT32 None = 0
 No flags More...
 
static const ON__UINT32 Recursive = 4
 Pass in this flag to get the render meshes for entire blocks. Only has an effect if the ObjectId is a block reference, and if it will not produce CRMs of its own. More...
 

Detailed Description

Flags to be passed into and returned from RenderMeshes and HasCustomRenderMeshes.

Member Data Documentation

◆ Canceled

const ON__UINT32 RhRdk::CustomRenderMeshes::IManager::Flags::Canceled = 1
static

If this flag is set when returned, then CustomMeshes was canceled.

◆ DisableCaching

const ON__UINT32 RhRdk::CustomRenderMeshes::IManager::Flags::DisableCaching = 2
static

Pass in this flag to bypass any primitive caching that the MeshProviders might do.

◆ None

const ON__UINT32 RhRdk::CustomRenderMeshes::IManager::Flags::None = 0
static

No flags

◆ Recursive

const ON__UINT32 RhRdk::CustomRenderMeshes::IManager::Flags::Recursive = 4
static

Pass in this flag to get the render meshes for entire blocks. Only has an effect if the ObjectId is a block reference, and if it will not produce CRMs of its own.