Click or drag to resize

GH_Document Events

The GH_Document type exposes the following members.

Events
  NameDescription
Public eventContextChanged
The context for this document was changed.
Public eventStatic memberDefaultPreviewColourChanged
This even is raised whenever the global default for Normal preview colour is changed.
Public eventStatic memberDefaultSelectedPreviewColourChanged
This even is raised whenever the global default for Selected preview colour is changed.
Public eventEnabledChanged
The Enabled state was changed on this document.
Public eventStatic memberEnableSolutionsChanged
Raised whenever the Shared EnabledSolutions property is changed.
Public eventFilePathChanged
Raised whenever the FilePath of the document is modified.
Public eventModifiedChanged
The modified flag on the document was changed.
Public eventObjectsAdded
Raised after a collection of objects was added to the document.
Public eventObjectsDeleted
Raised after a collection of objects was removed from the document. At this point, the objects still exist, but they no longer belong to this document.
Public eventSettingsChanged
Some settings of the document were changed.
Public eventSolutionEnd
This event is raised whenever a new solution request has been handled. Even if the document is locked.
Public eventSolutionStart
This event is raised whenever a new solution is requested. Even if the document is locked.
Public eventUndoStateChanged
Raised whenever there is a change to the document undo/redo stack.
Top
See Also