Click or drag to resize

Grasshopper.Kernel Namespace

The Kernel namespace contains all the classes that make up the logical backbone of the plug-in.
Classes
  ClassDescription
Public classGH_ActiveObject
Basic implementation of IGH_ActiveObject interface. Derive from this class rather than implementing IGH_ActiveObject to make your life easier.
Public classGH_Alias
Represents a single alias|target combo.
Public classGH_AssemblyInfo
Implement this interface once (and once only) in a GHA project if you wish to add additional information about your library to Grasshopper. Note you must supply an empty constructor.
Public classGH_AssemblyInfoStub
Provides basic properties for a GHA assembly that does not expose a type that derives from GH_AssemblyInfo. This type is created automatically when a GH_AssemblyInfo type is not found in an assembly.
Public classGH_AssemblyPriority
Derive from this class if you wish to perform additional steps before any of your components are loaded. Any class in your project which inherits from GH_AssemblyPriority and which has an empty constructor will be instantiated prior to any GH_Component or IGH_DocumentObject classes.
Public classGH_AttributesT
Derive from this class rather than implementing IGH_Attributes from scratch.
Public classGH_AttributesChangedEventArgs
Event arguments passed during AttributesChanged events.
Public classGH_Author
Maintains author information such as name, company, copyright, address etc.
Public classGH_AutoSaveSettings
Provides access to all AutoSave event flags.
Public classGH_BakeUtility
A utility class for baking. We heavily recommend you use this for any baking, as it handles invalid objects correctly.
Public classGH_CharPatternParamNameConstructor Obsolete.
Public classGH_Component
Inherit from this class if you wish to create a custom component. Note that you must provide a public, empty constructor which calls the base class constructor.
Protected classGH_ComponentGH_InputParamManager
This class is used during Component construction to add input parameters.
Protected classGH_ComponentGH_OutputParamManager
This class is used during Component construction to add output parameters.
Public classGH_ComponentParamServer
Wraps all members and functions needed for GH_Component to manage its input and output parameters.
Public classGH_ComponentServer
Maintains proxies for all components, parameters and other object types as defined in all grasshopper assemblies.
Public classGH_ConnectivityDiagram
Represents a complete connectivity diagram (topology) of a GH_Document. A connectivity diagram is basically an undirected network of all the wires in a document.
Public classGH_ConnectivityDisparity
Maintains two connectivity diagrams, one of which is a subset of the other.
Public classGH_ConnectivityNode
Represents a single node in a Grasshopper connectivity diagram. A single node represents a single IGH_Param instance.
Public classGH_Convert
Provides static converters for different data types inside Grasshopper. This class both has specific and generic converters.
Public classGH_CustomEventServer
RhinoCommon only event server.
Public classGH_DebugDescriptionWriter
Writer object used to create debug logs.
Public classGH_DisplayExpiredEventArgs
Arguments for display events.
Public classGH_DocContextEventArgs
These arguments are passed along with SettingsChanged events on GH_Document.
Public classGH_DocEnabledEventArgs
These arguments are passed along with SettingsChanged events on GH_Document.
Public classGH_DocFilePathEventArgs
These arguments are passed along with FilePathChanged events on GH_Document.
Public classGH_DocModifiedEventArgs
These arguments are passed along with ModifiedChanged events on GH_Document.
Public classGH_DocObjectEventArgs
These arguments are passed along with ObjectsAdded and ObjectsRemoved events on GH_Document.
Public classGH_DocSettingsEventArgs
These arguments are passed along with SettingsChanged events on GH_Document.
Public classGH_Document
Represents a single Grasshopper document.
Public classGH_DocumentAssociations
Public classGH_DocumentEventServer
RhinoCommon only event server.
Public classGH_DocumentIO
Provides basic IO operations for GH_Documents.
Public classGH_DocumentObject
Standard implementation of IGH_DocumentObject.
Public classGH_DocumentRenderMeshProvider
Utility class for seeding render queues with GH geometry.
Public classGH_DocumentServer
Manages and maintains a collection of GH_Documents.
Public classGH_DocumentTree
Represents a hierarchical tree of documents that are subsidiary to one another.
Public classGH_DocumentTreeNode
Represents a single node in a document tree.
Public classGH_DocUndoEventArgs
These arguments are passed along with UndoStateChanged events on GH_Document.
Public classGH_ExternalFile
Represents information about external files to be loaded.
Public classGH_FileSystemEventServer
Provides a easy-to-use way to keep tabs on files.
Public classGH_FileWatcher
Provides easy mechanisms to monitor changes to the local File System.
Public classGH_FontServer
Maintains a collection of standard fonts and mays to measure them.
Public classGH_Format
Provides standard Grasshopper formatting functions.
Public classGH_GHALoadingEventArgs
Event arguments used in the GH_GHALoaded event on GH_ComponentServer.
Public classGH_GHXHarvester
Provides static methods for harvesting data from GHX and GH files.
Public classGH_InstanceDescription
Base implementation of IGH_InstanceDescription. Consider deriving from this class rather than implementing IGH_InstanceDescription from scratch.
Public classGH_LineParser
Provides basic functionality for the custom ReadFile component script parsing.
Public classGH_ListUtil
Provides utilities for dealing with list of Data from input parameters.
Public classGH_LoadingAttribute
Assembly loading behaviour attribute.
Public classGH_MemoryBitmap
Utility class for ultra-fast bitmap sampling and filters.
Public classGH_ObjectChangedEventArgs
Event arguments passed during ObjectChanged events.
Public classGH_ParamT
Base implementation of IGH_Param. Derive from this class rather than implementing IGH_Param from scratch. If your parameter can store persistent data, derive from GH_PersistentParam(Of T) instead.
Public classGH_ParameterContext
Data passed to IGH_ContextualParameter.AutoAssignContextualData to help define a context state of Rhino/Grasshopper
Public classGH_ParamServerEventArgs
Arguments used in events for the GH_ComponentParamServer type.
Public classGH_PersistentGeometryParamT
Derives from GH_PersistentParam(Of T), but adds some useful functions for dealing with geometric data types.
Public classGH_PersistentParamT
Implementation of GH_Param(Of T) that supports persistent data.
Public classGH_PingDocumentEventArgs
Event arguments passed during PingDocument events.
Public classGH_PreviewArgs
This class is passed to Objects that implement IGH_PreviewObject during drawing operations.
Public classGH_PreviewBoundary
A closed boundary for filtering previewed objects.
Public classGH_PreviewExpiredEventArgs
Arguments for preview events.
Public classGH_PreviewMeshArgs
This class is passed to objects that implement IGH_PreviewData during mesh drawing operations.
Public classGH_PreviewUtil
This class exposes functionality that makes it easy to draw temporary geometry in Rhino viewports.
Public classGH_PreviewWireArgs
This class is passed to objects that implement IGH_PreviewData during wire drawing operations.
Public classGH_RelevantObjectData
Contains information about relevant objects at a specific canvas location.
Public classGH_RenderArgs
This class is passed to objects that implement IGH_RenderAwareData or IGH_RenderAwareObject during render queue operations.
Public classGH_RuntimeMessage
Contains all fields that together define a RuntimeMessage. Runtime Messages are created and recorded by document objects during Grasshopper solutions.
Public classGH_SettingsServer
A single instance of this class is maintained at module level under the accessor "Settings".
Public classGH_SolutionEventArgs
Event arguments used for Document Solution events.
Public classGH_SolutionExpiredEventArgs
Arguments for solution events.
Public classGH_State
Represents a single recorded document state. A state contains values for an arbitrary set of objects inside the document.
Public classGH_StateServer
Maintains all the recorded states for this document.
Public classGH_StateTag
Abstract implementation of the IGH_StateTag interface. Derive from this class rather than implementing IGH_StateTag.
Public classGH_StateTagList
Maintains a collection of IGH_StateTag objects.
Public classGH_TaskCapableComponentT
Abstract implementation of IGH_TaskCapableComponent. Inherit from this class instead of implementing IGH_TaskCapableComponent directly.
Public classGH_TypeLib
Utility module that caches a number of oft-used types and type-ids for quick access. Do not change any of the values in this module or you'll wreck casting and conversion logic.
Public classGH_UpgradeUtil
Exposes several utility functions for migrating parameters and wires between components useful while upgrading components.
Public classGH_UserObject
Represents a custom user object. A User Object is an existing IGH_DocumentObject with overridden icon, instance description and exposure.
Public classGH_ValueProxyT
Represents the abstract base implementation of the IGH_ValueProxy interface.
Public classGH_ZuiAction
Basic implementation of IGH_ZuiAction.
Structures
  StructureDescription
Public structureGH_AssemblyFolderInfo
Represents a folder from which GHA files are loaded.
Public structureGH_SolutionSpan
Represents the time interval for a GH_Document solution.
Interfaces
  InterfaceDescription
Public interfaceGH_ComponentParamServerIGH_SyncObject
Synch object for tracking long term changes to the parameter server.
Public interfaceIGH_ActiveObject
Base interface for all objects on the canvas that participate in solutions
Public interfaceIGH_Attributes
Base interface for all Attributes. Attributes are the visual portion of GH_DocumentObjects. They handle display, mouse events, layout, context menus etc. etc. You should consider inheriting from GH_Attributes or some other abstract class instead of implementing this interface from scratch.
Public interfaceIGH_Author
Provides of collection of basic author details.
Public interfaceIGH_BakeAwareData
Implement this interface in your IGH_Goo data type if you want to be included in baking operations.
Public interfaceIGH_BakeAwareObject
Implement this interface on your IGH_ActiveObject if you want to participate in the Bake GUI.
Public interfaceIGH_Component
Base interface for all GH_Component types. Do not implement this interface from scratch, inherit from GH_Component instead.
Public interfaceIGH_ContextualParameter
Base interface for contextual parameters. This makes accessing non-strongly-typed functionality easier.
Public interfaceIGH_DataAccess
Provides access to component parameters, in order to retrieve and assign data during solutions.
Public interfaceIGH_DebugDescription
Implement this interface to participate in Debug Logging.
Public interfaceIGH_DocumentObject
Base interface for objects that want to play on the Canvas. Do not implement this interface from scratch. Either inherit from GH_DocumentObject or one of the other partially finished types such as GH_ActiveObject, GH_Param(Of T) or GH_Component.
Public interfaceIGH_DocumentOwner
Implement this interface if you want to be the owner assigned to a document in the Grasshopper documentserver.
Public interfaceIGH_EventConsumer
Implement this interface if you want to inter-operate with a GH_EventServer.
Public interfaceIGH_InitCodeAware
Implement this interface in your IGH_DocumentObject class if you want to handle initialization codes from Canvas Search boxes.
Public interfaceIGH_InstanceDescription
Base interface for all objects that participate in the Grasshopper GUI.
Public interfaceIGH_InstanceGuidDependent
Implement this interface in your IGH_DocumentObject class if you want to be informed when the InstanceGuids of objects in the document are mutated.
Public interfaceIGH_ObjectProxy
Provides proxy data for all Grasshopper components and parameters.
Public interfaceIGH_Param
Base interface for all Parameter types in Grasshopper. Do not implement this interface from scratch, derive from GH_Param or GH_PersistentParam instead.
Public interfaceIGH_PreviewArgs
Preview display arguments for IGH_PreviewObjects.
Public interfaceIGH_PreviewData
All IGH_Goo types that wish to participate in Viewport redraws must implement this interface.
Public interfaceIGH_PreviewMeshData
Implement this interface if your data deals with preview meshes.
Public interfaceIGH_PreviewObject
All IGH_DocumentObjects that wish to participate in Viewport redraws must implement this interface.
Public interfaceIGH_RenderAwareData
Implement this interface in your IGH_Goo type if you wish to send geometry to a render queue.
Public interfaceIGH_RenderAwareObject Obsolete.
Implement this interface in your IGH_DocumentObject type if you wish to send geometry to a render queue.
Public interfaceIGH_StateAwareObject
Implement this interface if you want to be included in state saving/loading.
Public interfaceIGH_StateTag
A StateTag is a visual feedback mechanism that reflects a certain local setting of an Object.
Public interfaceIGH_TaskCapableComponent
GH_Component that can choose to support the use of Tasks to compute solutions When UseTasks returns true, the component has it's SolveInstance enumeration called twice. The first pass (InPreSolve=True) is intended solely for collecting data and starting calculation tasks. The second pass (InPreSolve=False) takes results or the tasks and sets the output.
Public interfaceIGH_UpgradeObject
Create a class with an empty constructor that implements this interface if you want to provide an upgrade mechanism.
Public interfaceIGH_UserPromptAware
Implement this interface in your IGH_Param if you want to allow users to set data either through the menu or by double clicking.
Public interfaceIGH_ValueProxy
Public interfaceIGH_VariableParameterComponent
Implement this interface in your component if you want to enable variable parameter UI.
Public interfaceIGH_ZuiAction
Represents a single action which is only visible on screen above a certain zoom level.
Public interfaceIRcpAwareObject
Implement this interface in a parameter or component if you want to be publishable on the remote control panel.
Delegates
  DelegateDescription
Public delegateGH_AutoSaveSettingsAutoSaveFileFormatChangedEventHandler
Public delegateGH_AutoSaveSettingsEnableAutoSaveChangedEventHandler
Public delegateGH_AutoSaveSettingsSaveOnDataFlatteningChangedEventHandler
Public delegateGH_AutoSaveSettingsSaveOnDocumentUnloadChangedEventHandler
Public delegateGH_AutoSaveSettingsSaveOnObjectAddedChangedEventHandler
Public delegateGH_AutoSaveSettingsSaveOnObjectChangeChangedEventHandler
Public delegateGH_AutoSaveSettingsSaveOnObjectRemovedChangedEventHandler
Public delegateGH_AutoSaveSettingsSaveOnWireEventChangedEventHandler
Public delegateGH_ComponentParamServerParameterChangedEventHandler
Public delegateGH_ComponentParamServerParameterNickNameChangedEventHandler
Public delegateGH_ComponentParamServerParameterSourcesChangedEventHandler
Public delegateGH_ComponentServerGHAFileLoadedEventHandler
Public delegateGH_DocumentContextChangedEventHandler
Public delegateGH_DocumentDefaultPreviewColourChangedEventHandler
Public delegateGH_DocumentDefaultSelectedPreviewColourChangedEventHandler
Public delegateGH_DocumentEnabledChangedEventHandler
Public delegateGH_DocumentEnableSolutionsChangedEventHandler
Public delegateGH_DocumentFilePathChangedEventHandler
Public delegateGH_DocumentGH_ActiveObjectFilter
Public delegateGH_DocumentGH_ScheduleDelegate
Callback signature for Scheduled Solutions.
Public delegateGH_DocumentModifiedChangedEventHandler
Public delegateGH_DocumentObjectsAddedEventHandler
Public delegateGH_DocumentObjectsDeletedEventHandler
Public delegateGH_DocumentSettingsChangedEventHandler
Public delegateGH_DocumentSolutionEndEventHandler
Public delegateGH_DocumentSolutionStartEventHandler
Public delegateGH_DocumentUndoStateChangedEventHandler
Public delegateGH_DocumentObjectColourEventHandler
Public delegateGH_DocumentServerDocumentAddedEventHandler
Public delegateGH_DocumentServerDocumentRemovedEventHandler
Public delegateGH_FileSystemEventServerFileEvent
This delegate is called when changes to a certain file occur.
Public delegateGH_FileWatcherFileChanged
Delegate method for file change callbacks.
Public delegateGH_FileWatcherFileChangedSimple
Delegate method for file change callbacks.
Public delegateGH_FontServerConsoleFamilyChangedEventHandler
Public delegateGH_FontServerScriptFamilyChangedEventHandler
Public delegateGH_FontServerStandardFamilyChangedEventHandler
Protected delegateGH_StateTagDrawCallback
Drawing delegate.
Public delegateIGH_DocumentObjectAttributesChangedEventHandler
Public delegateIGH_DocumentObjectDisplayExpiredEventHandler
Public delegateIGH_DocumentObjectObjectChangedEventHandler
Public delegateIGH_DocumentObjectPingDocumentEventHandler
Public delegateIGH_DocumentObjectPreviewExpiredEventHandler
Public delegateIGH_DocumentObjectSolutionExpiredEventHandler
Enumerations
  EnumerationDescription
Public enumerationGH_Arrange
Enumerates possible types of object arrangement.
Public enumerationGH_AutoSaveTrigger
Different types of events that can cause an AutoSave.
Public enumerationGH_BitmapChannel
Lists all possible channels for 24 and 32 bit bitmaps.
Public enumerationGH_ClipboardType
Enumerates all possible clipboards for GH_DocumentIO operations.
Public enumerationGH_Conversion
Level flag for conversion algorithms.
Public enumerationGH_DataComparison
Enumerates all possible Data Matching algorithms for Components.
Public enumerationGH_DataMapping
Enumerates all parameter data mapping types.
Public enumerationGH_DocumentContext
Enumerates all possible (de)activation contexts for documents.
Public enumerationGH_DocumentRank
Enumerates all possible document rankings.
Public enumerationGH_DocumentSettings
Enumerates all possible types of settings for a GH_Document.
Public enumerationGH_Exposure
Lists the different kinds of GUI exposure an object can have.
Public enumerationGH_ExternalFileType
Enumerates the possible external files that Grasshopper is interested in.
Public enumerationGH_FileWatcherEvents
Enumerates all possible file watcher events. These can be combined.
Public enumerationGH_Filter
Enumerates all object Search filters.
Public enumerationGH_GetterResult
Enumerates typical getter results.
Public enumerationGH_GuidConflictSolution
Contains a list of all possible Assembly GUID conflict solutions
Public enumerationGH_IconDisplayMode
Lists all display modes that individual objects can have.
Public enumerationGH_LibraryLicense
Enumerates the possible library types for GHA assemblies.
Public enumerationGH_LineParserAction
Enumerates the possible actions a line parser can invoke.
Public enumerationGH_LoadingDemand
Enumerates all assembly loading behaviour demands.
Public enumerationGH_LoadingInstruction
Enumerates all external GHA loading process instructions.
Public enumerationGH_LoadingMechanism
Enumerates all assembly loading mechanisms.
Public enumerationGH_MatchLevel
All possible string matching schemes.
Public enumerationGH_MatchWeight
Weighting factors of string matches.
Public enumerationGH_ObjectEventType
Represents common changes which can cause the ObjectChanged event to be raised.
Public enumerationGH_ObjectSpecies
Contains all object species.
Public enumerationGH_ObjectType
Enumerates all types of object that can be referenced by a GH_ObjectProxy instance.
Public enumerationGH_ParamAccess
Enumerates the types of access that parameters support.
Public enumerationGH_ParamData
Enumerates the possible states of being for data inside a parameter.
Public enumerationGH_ParameterSide
Enumerates possible sides for variable parameters.
Public enumerationGH_ParamHashFields
Enumerates all accepted fields for hashing parameter data.
Public enumerationGH_ParamKind
Enumerates the different guises of parameter
Public enumerationGH_ParamWireDisplay
Enumerates the possible wire display types for parameters.
Public enumerationGH_PickBox
Represents the different ways in which picking rectangles can behave.
Public enumerationGH_PluginFolderType
Enumerates the possible folder types for GH_AssemblyFolderInfo
Public enumerationGH_PreviewFilter
Lists all possible Grasshopper preview filters.
Public enumerationGH_PreviewMesh
Enumerates possible meshing parameters for documents.
Public enumerationGH_PreviewMode
Lists all possible Grasshopper preview modes.
Public enumerationGH_PrincipalState
Enumerates the different possible states in which the masterness of a parameter can occur.
Public enumerationGH_ProcessStep
Enumerates all possible solution states in which the document can be.
Public enumerationGH_ProfilerMode
Lists all profiler modes.
Public enumerationGH_RelevantObjectFilter
Enumerates the possible filters to use in relevant object searches.
Public enumerationGH_RuntimeMessageLevel
Indicates the severity of a runtime message.
Public enumerationGH_SelectionState
Enumerates the possible effects of a specific selection operation.
Public enumerationGH_SelectionTopology
Enumerates the possible selection topologies.
Public enumerationGH_SettingsType
Lists all the data types available in the GH_SettingsServer class.
Public enumerationGH_SolutionMode
Enumerates all solution modes.
Public enumerationGH_SolutionPhase
The Phase flags are used to track object states during solutions.
Public enumerationGH_StateTagLayoutDirection
Enumerates the possible layout directions for parameter state tags.
Public enumerationGH_TimeKind
Enumerates the possible kinds that a System.DateTime value can imply.
Public enumerationGH_UndoOperation
Enumerates all possible types of undo operation.