Click or drag to resize

GH_Chunk Constructor (GH_Archive, String, Int32)

Constructor. You typically do not need to create your own Chunks. The GH_Archive class will create top-level chunks and existing chunks can create child chunks.

Namespace:  GH_IO.Serialization
Assembly:  GH_IO (in GH_IO.dll)
Syntax
protected GH_Chunk(
	GH_Archive chunk_archive,
	string chunk_name,
	int chunk_index
)

Parameters

chunk_archive
Type: GH_IO.SerializationGH_Archive
Owner archive.
chunk_name
Type: SystemString
Name of this chunk.
chunk_index
Type: SystemInt32
Index of this chunk.
See Also