Click or drag to resize

GH_IO.Serialization Namespace

Namespace in GH_IO.dll that contains all the classes used during (de)serialization.
Classes
  ClassDescription
Public classGH_Archive
This is the base archive class which takes care of all (de)serialization and messaging.
Public classGH_Chunk
Full implementation of GH_IChunk, GH_IReader, GH_IWriter, GH_IBinarySupport and GH_IXmlSupport. Instances of this class are usually disguised as one of the interfaces it implements.
Public classGH_ChunkChunkKeyedCollection
Represents a collection of chunks with associated IDs
Public classGH_Compression
Provides static methods for compression of byte-arrays.
Public classGH_LooseChunk
A utility class for creating partial archives.
Public classGH_Message
Represents an archive log message. Messages are collected during read/write operations.
Structures
  StructureDescription
Public structureID
An ID is used to uniquely identify a specific item.
Interfaces
  InterfaceDescription
Public interfaceGH_IBinarySupport
Interface which declares all methods required for objects that can be (de)serialized to and from a binary archive.
Public interfaceGH_IChunk
Base interface for all Archive Chunks.
Public interfaceGH_IReader
Provides access to a subset of GH_Chunk methods used for reading archives.
Public interfaceGH_IWriter
Provides access to a subset of GH_Chunk methods used for writing archives.
Public interfaceGH_IXmlSupport
Interface which declares all methods required for objects that can be (de)serialized to and from an Xml archive.
Enumerations
  EnumerationDescription
Public enumerationGH_Message_Type
Message type flag.