Click or drag to resize

DataTreeTAddRange Method (IEnumerableT, GH_Path)

Add (append) a list of data items to the specified branch in the tree. If the branch doesn't exist yet, it will be created.

Namespace:  Grasshopper
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void AddRange(
	IEnumerable<T> data,
	GH_Path path
)

Parameters

data
Type: System.Collections.GenericIEnumerableT
Data to append.
path
Type: Grasshopper.Kernel.DataGH_Path
Data path.
See Also