Click or drag to resize

DataTreeT Constructor (IEnumerableT, GH_Path)

Create a tree with a single branch

Namespace:  Grasshopper
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public DataTree(
	IEnumerable<T> data,
	GH_Path root = null
)

Parameters

data
Type: System.Collections.GenericIEnumerableT
Data to append to the tree.
root (Optional)
Type: Grasshopper.Kernel.DataGH_Path
Branch path of first branch. If Null, the default path is used.
See Also