Click or drag to resize

GH_CapsuleRenderEngineCreateHighlightBar Method (Rectangle, Int32, Int32)

Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GraphicsPath CreateHighlightBar(
	Rectangle rec,
	int radius,
	int size
)

Parameters

rec
Type: System.DrawingRectangle
Rectangle for entire fill.
radius
Type: SystemInt32
Corner radius.
size
Type: SystemInt32
Highlight fill height.

Return Value

Type: GraphicsPath
Graphics path that describes the highlight fill shape.
See Also