Click or drag to resize

GH_CapsuleRenderEngineRenderIcon Method (Graphics, Image, Int32, Int32)

Render an image icon centered into the box. If the content box has been defined the icon will be centered there, otherwise the outline box will be used.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void RenderIcon(
	Graphics G,
	Image icon,
	int offsetX = 0,
	int offsetY = 0
)

Parameters

G
Type: System.DrawingGraphics
Graphics surface to draw onto.
icon
Type: System.DrawingImage
Icon to draw.
offsetX (Optional)
Type: SystemInt32
Additional x-offset (in original pixel units).
offsetY (Optional)
Type: SystemInt32
Additional y-offset (in original pixel units).
See Also