Click or drag to resize

GH_SettingsCategory Constructor (String, String, Bitmap)

Create a new nested category.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
protected GH_SettingsCategory(
	string name,
	string parent,
	Bitmap icon
)

Parameters

name
Type: SystemString
Category name, keep it short.
parent
Type: SystemString
Name of parent category. If the parent category hasn't been defined, the category will be placed under a "Misc" category.
icon
Type: System.DrawingBitmap
Category icon. If you supply an icon, it must be 48x48 pixels. If you supply a null instance, a generic Settings icon will be assigned.
See Also