Click or drag to resize

Grasshopper.GUI Namespace

Namespace for all things GUI. This namespace contains practically all the custom Form and Control classes used in Grasshopper, but it also contains many utility functions and classes. Note that many specific classes have been excluded from this helpfile as they are either very obtuse or overly specific.
Classes
  ClassDescription
Public classGH_Animator
Provides static methods and constructors GH_Animator(Of T).
Public classGH_Animator<T>
Provides methods for animating values.
Public classGH_AsynchFileData
This class provides asynchronous methods to keep tabs on a file.
Public classGH_BezierSolver
Class for evaluating four-point bezier curves as used in GDI+
Public classGH_CanvasMouseEvent
Class used in Canvas UI events.
Public classGH_CanvasObjectMouseDownEventArgs
Event arguments for the CanvasObjectMouseDown events.
Public classGH_ColourPicker
Provides the standard Grasshopper Colour picker as a winforms Control.
Public classGH_ColourSwatchEventArgs
Event arguments used in the GH_ColourSwatchControl.ColourChanged event.
Public classGH_CursorServer
Class used to cache and set cursors.
Public classGH_DebugLogForm
Public classGH_DigitScroller
Provides the standard Grasshopper Digit scroller as a winforms Control.
Public classGH_DocumentEditor
The Grasshopper main window.
Public classGH_DoubleBufferedPanel
Derives from Windows.Forms.Panel but overrides certain flags that improve on-screen rendering. Use panel if you want to have a custom drawn control that is under the control of the owner form.
Public classGH_DragInfo
Contains data used for UI drag operations.
Public classGH_EtoUtil
Public classGH_ExternalFileConflictDialog
Public classGH_FadeAnimation
Utility class for animating fade ZUI events on the canvas.
Public classGH_FontControl
Represents a control that offers both Font preview and Picking methods.
Public classGH_FontList
Represents the installed Font collection. This control allows both navigation and selection of Font Families.
Public classGH_FontPicker
Public classGH_FontScroller
Represents a panel with a scrolling collection of pangrams.
Public classGH_FormShepard
A Form shepard is used to herde a bunch of floating forms. Important forms that potentially spout child forms might choose to implement one.
Public classGH_GDI_Util
Contains some global function for filleting corners of GDI objects.
Public classGH_GeometricFont
Exposes methods for drawing geometric characters.
Public classGH_GraphicsUtil
Utility class with static (Shared) functions that help with colour, shape and text rendering.
Public classGH_HorizontalSeparator
GUI elements for creating visual separations.
Public classGH_IconLabel
A simple Icon with an icon overlay plus highlight rectangle.
Public classGH_IconPicker
Provides a standard icon selection interface.
Public classGH_LoadProtectDialog
Public classGH_MaterialPreviewControl
Offers a frontend for Grasshopper Material previews.
Public classGH_MenuTextBox
Utility control for putting textboxes into menus.
Public classGH_MouseTracker
Record mouse-movements over time.
Public classGH_NumberSliderSnappingEditor
Public classGH_PanelEditorControl
Public classGH_QuickImageEditor
Public classGH_RotationalTuningData<T>
Utility class for keeping track of rotational mouse events.
Public classGH_SamplingSphere
Represents a coloured sphere that can be sampled at various rotations.
Public classGH_SettingsCategory
Base implementation of IGH_SettingsCategory. Derive from this class and provide an empty constructor to play ball.
Public classGH_Slider
Provides a standard Grasshopper slider as a winforms control.
Public classGH_Slider_Obsolete
General purpose numeric slider.
Public classGH_StandardIcons
Provides access to a set of standard icons.
Public classGH_Tooltip
Implements a custom Tooltip class with advanced functionality. All methods and fields are Shared. There can never be more than one GH_Tooltip.
Public classGH_TooltipComponent
This component provides Grasshopper tooltip functionality through a winforms Component.
Public classGH_TooltipDisplayEventArgs
Event arguments used in the Tooltip Component.
Public classGH_UnrecognizedObjectsForm
Public classGH_VerticalScrollBar
Scroll bar control with floating point accuracy.
Public classGH_VerticalSeparator
GUI elements for creating visual separations.
Public classGH_VoronoiWarningForm
Public classGH_WindowsControlUtil
Exposes some static (Shared) utility functions for setting text-rendering properties en masse.
Public classGH_WindowsFormUtil
Exposes some static (Shared) utility functions for positioning custom windows.
Public classGH_YakDownloadFormEto
Public classGH_YakDownloadFormEto.MissingObjectItem
Structures
  StructureDescription
Public structureGH_RotationalFrame
Represents a single frame in a rotational tuning history.
Public structureGH_TrackerFrame
Represents a single frame in a mouse-tracker history. A frame represents all relevant mouse and keyboard data at a given time.
Interfaces
  InterfaceDescription
Public interfaceIGH_Embeddable
Implement this interface in your custom control if you want to be called before a menu commits or cancels.
Public interfaceIGH_FileDropTarget
Implement this interface in your IGH_DocumentObject if you want to participate in Drag+Drop events.
Public interfaceIGH_SettingCategory
Represents a single category in the Settings UI. Implement this interface or derive from GH_SettingsCategory to add a new Category to the Grasshopper Settings interface.
Public interfaceIGH_SettingFrontend
Represents a single setting in the Settings UI. Implement this interface to participate in the Grasshopper Settings interface.
Public interfaceIGH_Tooltip
Accessor interface for the Grasshopper Tooltip form.
Delegates
  DelegateDescription
Public delegateGH_Animator<T>.Interpolate
Delegate for interpolating values.
Public delegateGH_AsynchFileData.FileChangedDelegate
Public delegateGH_ColourPicker.ColourChangedEventHandler
Public delegateGH_DigitScroller.ValueChangedEventHandler
Public delegateGH_DocumentEditor.AggregateShortcutMenuItemsEventHandler
Public delegateGH_DocumentEditor.EditorFoldStateChangedEventHandler
Public delegateGH_FontScroller.PostPaint
Public delegateGH_MaterialPreviewControl.ColourChangedEventHandler
Public delegateGH_MaterialPreviewControl.MaterialImagePostPaintEventHandler
Public delegateGH_MaterialPreviewControl.SelectedChangedEventHandler
Public delegateGH_MenuTextBox.KeyDownEventHandler
Public delegateGH_MenuTextBox.TextChangedEventHandler
Public delegateGH_Slider.ValueChangedEventHandler
Public delegateGH_Slider_Obsolete.ValueChangedEventHandler
Public delegateGH_TooltipComponent.PopulateTooltipEventHandler
Public delegateGH_VerticalScrollBar.ScrollRatioChangedEventHandler
Enumerations
  EnumerationDescription
Public enumerationGH_AnimationPhase
Enumerates the possible phases in which an animation can occur.
Public enumerationGH_Constraint
Constraints used during UI dragging operations.
Public enumerationGH_FadePhase
Enumerates the possible states of a ZUI fade animation.
Public enumerationGH_Interpolation
Enumerates the possible animation progression types.
Public enumerationGH_SeparatorDisplay
Enumerates all possible display modes for horizontal and vertical separators.
Public enumerationGH_SliderInputMode
Enumerates all possible slider text input modes.