Click or drag to resize

GH_GradientNearestGrip Method (RectangleF, PointF, Double)

Find the nearest grip in screen coordinates.

Namespace:  Grasshopper.GUI.Gradient
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public int NearestGrip(
	RectangleF dest,
	PointF pt,
	double maxRadius
)

Parameters

dest
Type: System.DrawingRectangleF
Retangle that contains the entire gradient.
pt
Type: System.DrawingPointF
Point to search from.
maxRadius
Type: SystemDouble
Maximum distance between point and grip.

Return Value

Type: Int32
The grip closest to the point.
See Also