Click or drag to resize

GH_StructureT Constructor (GH_StructureT, Boolean)

Copy constructor, duplicate another data structure.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public GH_Structure(
	GH_Structure<T> other,
	bool shallowCopy
)

Parameters

other
Type: Grasshopper.Kernel.DataGH_StructureT
Structure to copy, if null, this structure will be empty.
shallowCopy
Type: SystemBoolean
If True, data item pointers are shared among this and the [other] structure.
See Also