Click or drag to resize

GH_ExpressionParserIsValidVariableName Method

Tests whether a string is a valid variable name for expressions. Valid names must contain at least one character, must start with an alphabetic character, and only contain alphanumeric chars and underscores.

Namespace:  Grasshopper.Kernel.Expressions
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static bool IsValidVariableName(
	string name
)

Parameters

name
Type: SystemString
Name to test.

Return Value

Type: Boolean
True if the name is valid (might still conflict with a function name though), false if not.
See Also