Click or drag to resize

GH_ComponentParamServerInventUniqueNickname Method (String, IEnumerableString)

Create a new, unique parameter name.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static string InventUniqueNickname(
	string allowedChars,
	IEnumerable<string> existingNames
)

Parameters

allowedChars
Type: SystemString
Allowed character set for naming logic.
existingNames
Type: System.Collections.GenericIEnumerableString
A collection of parameter names to avoid.

Return Value

Type: String
The first name combination that doesn't occur in the existingNames collection.
See Also