Click or drag to resize

GH_DocumentNewSolution Method (Boolean, GH_SolutionMode)

Start a new solution.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void NewSolution(
	bool expireAllObjects,
	GH_SolutionMode mode
)

Parameters

expireAllObjects
Type: SystemBoolean
If True, all objects will be recalculated. If False, only already expired objects will be recalculated.
mode
Type: Grasshopper.KernelGH_SolutionMode
Solution mode. Only use CommandLine or Silent if your solution runs in the background.
See Also