Click or drag to resize

IGH_BakeAwareDataBakeGeometry Method

Bake an object in the given Rhino document.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
bool BakeGeometry(
	RhinoDoc doc,
	ObjectAttributes att,
	out Guid obj_guid
)

Parameters

doc
Type: RhinoDoc
Document to bake into.
att
Type: ObjectAttributes
Attributes to bake with (should not be null).
obj_guid
Type: SystemGuid
The id of the baked object.

Return Value

Type: Boolean
True on success. If False, obj_guid and obj_inst are not guaranteed to be valid pointers.
See Also