Click or drag to resize

IGH_UpgradeObjectUpgrade Method

Upgrade an existing object.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
IGH_DocumentObject Upgrade(
	IGH_DocumentObject target,
	GH_Document document
)

Parameters

target
Type: Grasshopper.KernelIGH_DocumentObject
Object to upgrade.
document
Type: Grasshopper.KernelGH_Document
Document that contains the object.

Return Value

Type: IGH_DocumentObject
The newly created object on success, null on failure.
See Also