Click or drag to resize

GH_ArchivedUndoActionDeserialize Method

Deserializes the obj from the local archive.

Namespace:  Grasshopper.Kernel.Undo
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
protected void Deserialize(
	GH_ISerializable obj
)

Parameters

obj
Type: GH_IOGH_ISerializable
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when obj is a null reference.
NullReferenceExceptionThrown when the internal archive data is null.
IOExceptionThrown when the deserialization fails.
See Also