Click or drag to resize

GH_MouseTracker Methods

The GH_MouseTracker type exposes the following members.

Methods
  NameDescription
Public methodDeviation
Gets the maximum deviation of the recorded mouse path. The maximum deviation is the furthest distance the mouse has been from the first point in the history record.
Public methodDeviation(DateTime, DateTime)
Gets the maximum deviation of the recorded mouse path. The maximum deviation is the furthest distance the mouse has been from the first point in the history span. It does not measure the largest deviation between any two points in the time span, only the first and any subsequent point.
Public methodDropFrames(DateTime)
Drop all frames older than a given limit.
Public methodDropFrames(Double)
Find the youngest frame that deviates too much from the current locus and drop it and everything preceding it.
Public methodDropFrames(Double, Point)
Find the youngest frame that deviates too much from the given locus and drop it and everything preceding it.
Public methodLastFrameWithinDeviation
Starting from the youngest frame, finds the oldest frame that is still within a maximum deviation of the youngest frame.
Public methodRecord(Point)
Record a new mouse event frame. If this frame is closer than [Accuracy]ms to the previously recorded frame, it is not included.
Public methodRecord(Point, Object)
Record a new mouse event frame. If this frame is closer than [Accuracy]ms to the previously recorded frame, it is not included.
Public methodToString (Overrides ObjectToString.)
Top
See Also