Click or drag to resize

Instances Methods

The Instances type exposes the following members.

Methods
  NameDescription
Public methodStatic memberDocumentEditorFadeIn
Calls the FadeIn() method on the DocumentEditor if it exists.
Public methodStatic memberDocumentEditorFadeOut
Calls the FadeOut() method on the DocumentEditor if it exists.
Public methodStatic memberEnforceInvariantCulture
If the Setting "EnforceInvariantCulture" is set to False, this function does nothing
Public methodStatic memberHideRemotePanel
Hides the remote control panel.
Public methodStatic memberInterop
Gets the Grasshopper 1.0 interop object, i.e. an instance of GrasshopperPlugin.GrasshopperInterop as exposed via the GetInteropObject() method on the Grasshopper 1.0 plugin object.
Public methodStatic memberInvalidateCanvas
Invalidates the currently active Grasshopper Canvas, causing a redraw sometime in the foreseeable future.
Public methodStatic memberRedrawAll
Forces a redraw of both the active canvas and the Rhino viewports.
Public methodStatic memberRedrawCanvas
Forces a redraw of the currently active Grasshopper Canvas.
Public methodStatic memberReloadMemoryAssemblies
Unload and attempt to reload all plugin assemblies that were loaded via the COFF pipeline.
Public methodStatic memberShowRemotePanel
Shows the remote control panel.
Public methodStatic memberUnloadAllObjects
Clears and unloads all cached objects. This function is called by the _GrasshopperUnloadPlugin command. Please don't use it.
Top
See Also