Click or drag to resize

Instances Class

Provides access to a bunch of global instances and variables.
Inheritance Hierarchy
SystemObject
  GrasshopperInstances

Namespace:  Grasshopper
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class Instances

The Instances type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberActiveCanvas
Gets the currently active Grasshopper canvas (if any)
Public propertyStatic memberAutoHideBanner
Gets or sets a value indicating whether the banner ought to be hidden automatically when loading completes.
Public propertyStatic memberAutoShowBanner
Gets or sets a value indicating whether or not the banner will be displayed during the ComponentServer Loading process.
Public propertyStatic memberComponentServer
Gets the ComponentServer instance cached by the Instance Server. The ComponentServer will be instantiated the first time this property accessed. This is a rather involved process during which the Grasshopper Banner will be displayed.
Public propertyStatic memberCursorServer
Gets the CursorServer instance cached by the Instance Server. The CursorServer will be instantiated the first time this property is accessed.
Public propertyStatic memberDocumentAssociationServer
Gets the Document Association Server instance cached by the Instance Server. The Document Association Server will be instantiated the first time this property accessed.
Public propertyStatic memberDocumentEditor
Gets the DocumentEditor of Grasshopper.
Public propertyStatic memberDocumentServer
Gets the DocumentServer instance cached by the Instance Server. The DocumentServer will be instantiated the first time this property accessed.
Public propertyStatic memberEtoDocumentEditor
Public propertyStatic memberGrasshopperPluginId
Gets the ID of the Grasshopper Plugin.
Public propertyStatic memberIsComponentServer
Gets whether the Component server has been set.
Public propertyStatic memberIsCursorServer
Gets whether the Cursor server has been set.
Public propertyStatic memberIsDocumentAssociationServer
Gets whether the Document Association server has been set.
Public propertyStatic memberIsDocumentEditor
Gets whether the Document Editor has been set.
Public propertyStatic memberIsDocumentEditorOnTopOfViewports
Gets whether the Grasshopper document editor (or any of its child forms) is obscuring a significant part of the Rhino viewports.
Public propertyStatic memberIsDocumentServer
Gets whether the Document server has been set.
Public propertyStatic memberIsMarkovChain
Gets a value indicating whether or not the MarkovChain has already been initialized.
Public propertyStatic memberIsMruServer
Gets a value indicating whether or not the MRU server has been initialized.
Public propertyStatic memberIsRemotePanelVisible
Gets whether the Remote Control Panel is currently visible.
Public propertyStatic memberMarkovChain
Gets the MarkovChain instance cached by the Instance Server. The Markov chain will be instantiated if it hasn't been already.
Public propertyStatic memberMruServer
Gets the MRU_Server instance cached by the Instance Server. The MRU_Server will be instantiated the first time this property accessed.
Public propertyStatic memberRcpPanel
Gets the app-domain wide RCP panel instance. If it doesn't exist yet it will be created.
Public propertyStatic memberRunningHeadless
Public propertyStatic memberSettings
Represents the default settings database. Feel free to add your own settings to this database.
Top
Methods
  NameDescription
Public methodStatic memberDocumentEditorFadeIn
Calls the FadeIn() method on the DocumentEditor if it exists.
Public methodStatic memberDocumentEditorFadeOut
Calls the FadeOut() method on the DocumentEditor if it exists.
Public methodStatic memberEnforceInvariantCulture
If the Setting "EnforceInvariantCulture" is set to False, this function does nothing
Public methodStatic memberHideRemotePanel
Hides the remote control panel.
Public methodStatic memberInvalidateCanvas
Invalidates the currently active Grasshopper Canvas, causing a redraw sometime in the foreseeable future.
Public methodStatic memberRedrawAll
Forces a redraw of both the active canvas and the Rhino viewports.
Public methodStatic memberRedrawCanvas
Forces a redraw of the currently active Grasshopper Canvas.
Public methodStatic memberReloadMemoryAssemblies
Unload and attempt to reload all plugin assemblies that were loaded via the COFF pipeline.
Public methodStatic memberShowRemotePanel
Shows the remote control panel.
Public methodStatic memberUnloadAllObjects
Clears and unloads all cached objects. This function is called by the _GrasshopperUnloadPlugin command. Please don't use it.
Top
Events
  NameDescription
Public eventStatic memberCanvasCreated
Raised when the main canvas is created.
Public eventStatic memberCanvasDestroyed
Raised when the main canvas is destroyed.
Top
Fields
  NameDescription
Public fieldStatic memberLoadOneByOne
Top
See Also