Click or drag to resize

GH_Archive Properties

The GH_Archive type exposes the following members.

Properties
  NameDescription
Public propertyFileName
Gets the filename (without extension) of the currently loaded data tree. If the path field has not been set, "unnamed" is returned.
Public propertyGetRootNode
Gets the root node of this archive. Typically you do not need to modify the Root. Use functions like CreateTopLevelNode(), AppendObject() and ExtractObject() instead. If you modify the Root node, you may corrupt the archive.
Public propertyStatic memberGH_IO_Version
Gets the version number of the current GH_IO build.
Public propertyStatic memberGrasshopperBinaryExtension
Gets the file extension (including the dot) associated with Grasshopper® Binary data.
Public propertyStatic memberGrasshopperUserExtension
Gets the file extension (including the dot) associated with Grasshopper® User Object file.
Public propertyStatic memberGrasshopperXmlExtension
Gets the file extension (including the dot) associated with Grasshopper® XML data.
Public propertyIsBinaryPath
Gets a value that indicates whether the Path field points to a Binary Grasshopper file.
Public propertyIsPath
Gets a value that indicates whether or not the path field has been set.
Public propertyIsXmlPath
Gets a value that indicates whether the Path field points to an Xml Grasshopper file.
Public propertyMessages
Gets the internal list of messages.
Public propertyPath
Gets the path to the file from which this archive was read and/or written to. If the archive hasn't been read or written yet, this field will be null.
Public propertyWorstCaseMessageType
Gets the worst case message type. If the record contains at least 1 error, the worst case is GH_Message_Type.error. If the record contains no errors, but at least 1 warning, the worst case is GH_Message_Type.warning. If the record contains no messages or only infos, the worst case type is GH_Message_Type.info.
Top
See Also