Click or drag to resize

GH_ComponentParamServer Properties

The GH_ComponentParamServer type exposes the following members.

Properties
  NameDescription
Public propertyInput
Gets or sets the input list of parameters. Do not insert or remove parameters from this list, use the dedicated functions instead.
Public propertyInputWidth
Gets the width of the largest input parameter.
Public propertyOnlyTreeAndListParameters
Returns True if every input parameter is either a list or a tree parameter.
Public propertyOnlyTreeParameters
Returns True if every input parameter is a tree parameter.
Public propertyOutput
Gets or sets the output list of parameters. Do not insert or remove parameters from this list, use the dedicated functions instead.
Public propertyOutputWidth
Gets the width of the largest output parameter.
Public propertyOwner
Gets the owner component of this instance
Top
See Also