Click or drag to resize

GH_Link Class

Represents a link to another location in the Help or some external address.
Inheritance Hierarchy
SystemObject
  Grasshopper.DocumentationGH_Link

Namespace:  Grasshopper.Documentation
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Link : IGH_Content

The GH_Link type exposes the following members.

Properties
  NameDescription
Public propertyDestination
Gets the link target.
Public propertyIsSharedLink
Gets whether this link is a shared link. A shared link should not have text but it should have a non-empty LinkId.
Public propertyLinkId
Gets the link ID. The link ID is only used for shared links.
Public propertyTarget
Gets the link type.
Public propertyText
Gets the list text.
Public propertyTooltip
Gets the link tooltip text.
Top
Methods
See Also