Click or drag to resize

SliderSnapRange Structure

Represents a snap range on a slider.

Namespace:  Grasshopper.GUI.Base
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public struct SliderSnapRange : IComparable<SliderSnapRange>

The SliderSnapRange type exposes the following members.

Constructors
  NameDescription
Public methodSliderSnapRange(Decimal)
Initializes a new instance of the SliderSnapRange class
Public methodSliderSnapRange(Decimal, Decimal)
Initializes a new instance of the SliderSnapRange class
Top
Properties
  NameDescription
Public propertyIsSingleton
Public propertyMax
Public propertyMin
Top
Methods
  NameDescription
Public methodCanMerge
Public methodCompareTo
Public methodDistanceTo
Compute the distance from a value to this snap range.
Public methodMerge
Public methodSnapValue
Gets the snapped value of another value.
Top
See Also