Click or drag to resize

GH_CanvasDocumentChangedEventArgs Class

These arguments are used in the DocumentChanged event on GH_Canvas.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Grasshopper.GUI.CanvasGH_CanvasDocumentChangedEventArgs

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_CanvasDocumentChangedEventArgs : EventArgs

The GH_CanvasDocumentChangedEventArgs type exposes the following members.

Constructors
  NameDescription
Public methodGH_CanvasDocumentChangedEventArgs
Initializes a new instance of the GH_CanvasDocumentChangedEventArgs class
Top
Properties
  NameDescription
Public propertyNewDocument
Gets the document which has just been loaded into the canvas.
Public propertyOldDocument
Gets the document which was previously loaded into the canvas.
Top
See Also