Click or drag to resize

GH_MaterialPreviewControl Class

Offers a frontend for Grasshopper Material previews.
Inheritance Hierarchy

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_MaterialPreviewControl : UserControl

The GH_MaterialPreviewControl type exposes the following members.

Constructors
  NameDescription
Public methodGH_MaterialPreviewControl
Initializes a new instance of the GH_MaterialPreviewControl class
Top
Properties
  NameDescription
Public propertyColour
Gets or sets the colour of this preview.
Public propertySelected
Gets or sets the Selected state of this preview. Selected previews have thick borders drawn around them.
Public propertySelectOnClick
Gets or sets whether this control can be selected.
Top
Methods
  NameDescription
Protected methodDispose
Releases the unmanaged resources used by the GH_MaterialPreviewControl and optionally releases the managed resources
(Overrides ContainerControlDispose(Boolean).)
Top
Events
Extension Methods
  NameDescription
Public Extension MethodToEto (Defined by EtoExtensions.)
Top
See Also