Click or drag to resize

IGH_SettingFrontend Interface

Represents a single setting in the Settings UI. Implement this interface to participate in the Grasshopper Settings interface.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_SettingFrontend

The IGH_SettingFrontend type exposes the following members.

Properties
  NameDescription
Public propertyCategory
Category of this setting.
Public propertyKeywords
Optional keywords for this setting.
Public propertyName
Name of this setting.
Top
Methods
  NameDescription
Public methodSettingsUI
Create the winforms UI portion for this setting.
Top
See Also