Click or drag to resize

GH_PathPathLengthComparer Class

Use this comparer to sort lists of paths using a topological approach. Shorter paths are favoured over longer paths. Equal length paths use the default comparer.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.DataGH_PathPathLengthComparer

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class PathLengthComparer : IComparer<GH_Path>

The GH_PathPathLengthComparer type exposes the following members.

Constructors
  NameDescription
Public methodGH_PathPathLengthComparer
Initializes a new instance of the GH_PathPathLengthComparer class
Top
Methods
  NameDescription
Public methodCompare
Top
See Also