Click or drag to resize

GH_Author Class

Maintains author information such as name, company, copyright, address etc.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_Author

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Author : GH_ISerializable, IGH_Author

The GH_Author type exposes the following members.

Constructors
  NameDescription
Public methodGH_Author
Initializes a new instance of the GH_Author class
Public methodGH_Author(IGH_Author)
Initializes a new instance of the GH_Author class
Top
Properties
  NameDescription
Public propertyAddress
Public propertyCompany
Public propertyCopyright
Public propertyEMail
Public propertyIsEmpty
Gets whether any of the fields have been assigned.
Public propertyName
Public propertyPhone
Public propertyWebsite
Top
Methods
  NameDescription
Public methodClear
Erase all fields.
Public methodRead
Public methodWrite
Top
See Also