Click or drag to resize

GH_ConnectivityNode Class

Represents a single node in a Grasshopper connectivity diagram. A single node represents a single IGH_Param instance.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_ConnectivityNode

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ConnectivityNode

The GH_ConnectivityNode type exposes the following members.

Constructors
  NameDescription
Public methodGH_ConnectivityNode
Initializes a new instance of the GH_ConnectivityNode class
Top
Properties
  NameDescription
Public propertyNodeID
Gets the InstanceID of the Parameter that this node represents.
Public propertyNodeIn
Gets the list of IDs that are connected to the input of this node.
Public propertyNodeOut
Gets the list of IDs that are connected to the input of this node.
Top
See Also