Click or drag to resize

GH_CustomEventServer Class

RhinoCommon only event server.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_CustomEventServer

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_CustomEventServer

The GH_CustomEventServer type exposes the following members.

Constructors
  NameDescription
Public methodGH_CustomEventServer
Create and register a new event server.
Top
Properties
  NameDescription
Public propertyEnabled
Gets or sets the enabled state flag for this event watcher.
Public propertyGuidTable
Gets direct access to the internal guid table. The table contains pairs of object Ids and runtime serial numbers.
Public propertyGuidTableCount
Gets the number of stored ids in the Guid Table.
Top
See Also