Click or drag to resize

GH_DocObjectEventArgs Class

These arguments are passed along with ObjectsAdded and ObjectsRemoved events on GH_Document.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Grasshopper.KernelGH_DocObjectEventArgs

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DocObjectEventArgs : EventArgs

The GH_DocObjectEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Gets all the attributes that are associated with all objects in the event.
Public propertyDocument
Gets the document that raised the event.
Public propertyObject
Gets the object to which this event pertains.
Public propertyObjectCount
Gets the number of objects in this event.
Public propertyObjects
Gets a readonly list of the objects to which this event pertains.
Top
See Also