Click or drag to resize

GH_DocumentAssociations Class

Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_DocumentAssociations

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DocumentAssociations

The GH_DocumentAssociations type exposes the following members.

Constructors
  NameDescription
Public methodGH_DocumentAssociations
Initializes a new instance of the GH_DocumentAssociations class
Top
Methods
  NameDescription
Public methodAssociate
Add an association between a Rhino and a Grasshopper file. If a similar association already exists, it will be overwritten. This function reads and writes to the disk, it is SLOW. Only call it when you KNOW something changed.
Public methodGetGrasshopperAssociations
Find all the Grasshopper ghx files that have been associated with a given Rhino file.
Public methodGetRhinoAssociations
Find all the Rhino 3dm files that have been associated with a given Grasshopper file.
Top
See Also