Click or drag to resize

GH_DocumentEventServer Class

RhinoCommon only event server.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_DocumentEventServer

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DocumentEventServer : IGH_DebugDescription

The GH_DocumentEventServer type exposes the following members.

Constructors
  NameDescription
Public methodGH_DocumentEventServer
Create and register a new event server.
Top
Properties
  NameDescription
Public propertyEnabled
Gets or sets the enabled state flag for this event watcher.
Public propertyGuidTableRefCount
Gets the number of stored ids in the Guid Table.
Top
Methods
  NameDescription
Public methodAppendToDebugLog
Public methodClearGuidTable
Clear the entire ID table.
Public methodCreateGuidTable
Create the entire ID table from scratch.
Public methodEnsureGuidTable
Create the entire ID table if it doesn't exist yet.
Top
See Also