Click or drag to resize

GH_ExternalFile Class

Represents information about external files to be loaded.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_ExternalFile

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ExternalFile

The GH_ExternalFile type exposes the following members.

Constructors
  NameDescription
Public methodGH_ExternalFile
Create a new instance of the file info class
Top
Properties
  NameDescription
Public propertyFileHash
Gets the file hash.
Public propertyFileName
Gets the file name (without the extension).
Public propertyFilePath
Gets the file path.
Public propertyFileSize
Gets the file size (in bytes).
Public propertyFileType
Gets the file type as indicated by the extension.
Top
Methods
  NameDescription
Public methodIsIdenticalTo
Compares two files for content. If the size and the hash or the other file are equal to this one, the files are considered identical.
Top
See Also