Click or drag to resize

GH_ParamServerEventArgs Class

Arguments used in events for the GH_ComponentParamServer type.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Grasshopper.KernelGH_ParamServerEventArgs

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ParamServerEventArgs : EventArgs

The GH_ParamServerEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyOriginalArguments
Gets access to the original parameter event arguments.
Public propertyParameter
Gets the parameter that caused the original event.
Public propertyParameterIndex
Gets the index of the parameter that caused the original event.
Public propertyParameterSide
Gets the side of the parameter that caused the original event.
Public propertyServer
Gets the GH_ComponentParamServer object that raised the event.
Top
See Also