Click or drag to resize

GH_PreviewBoundary Class

A closed boundary for filtering previewed objects.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_PreviewBoundary

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_PreviewBoundary : GH_ISerializable

The GH_PreviewBoundary type exposes the following members.

Constructors
  NameDescription
Public methodGH_PreviewBoundary
Create a new preview boundary.
Top
Properties
  NameDescription
Public propertyBoundary
Gets the boundary region.
Public propertyLimits
Gets the limits of the boundary.
Public propertyPoints
Gets the array of points this boundary was made from.
Top
Methods
  NameDescription
Public methodIsVisible
Gets whether a specific object is visible within this boundary.
Public methodRead
Public methodWrite
Top
See Also