Click or drag to resize

GH_RelevantObjectData Class

Contains information about relevant objects at a specific canvas location.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_RelevantObjectData

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_RelevantObjectData

The GH_RelevantObjectData type exposes the following members.

Constructors
  NameDescription
Public methodGH_RelevantObjectData
Construct a new instance.
Top
Properties
  NameDescription
Public propertyAttributes
Gets the attributes that belong to the object.
Public propertyGroup
Gets the cast of the DocObject to GH_Group.
Public propertyIsTopLevelObject
Gets a value indicating whether or not the Object is a top-level object.
Public propertyObject
Gets the raw object cached in this data instance.
Public propertyObjectType
Gets the type of object indicated by this data.
Public propertyParameter
Gets the cast of the DocObject to IGH_Param. If the DocObject is not of type IGH_Param, the attributes of the object will be perused to find a nested IGH_Param at the point.
Public propertyPoint
Gets the point for which this GH_RelevantObjectData has been made.
Public propertyTopLevelObject
Gets the top-level object.
Top
Methods
See Also