Click or drag to resize

GH_SolutionEventArgs Class

Event arguments used for Document Solution events.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Grasshopper.KernelGH_SolutionEventArgs

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_SolutionEventArgs : EventArgs

The GH_SolutionEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyDocument
Gets the document that raised the event, should be the same as the "sender" parameter in the event handler.
Public propertyDuration
Gets the duration for this solution. The duration is a more accurate measure than EndTime-StartTime.
Public propertyStartTime
Gets the time when the current solution began.
Top
See Also