Click or drag to resize

GH_ValueProxyT Class

Represents the abstract base implementation of the IGH_ValueProxy interface.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_ValueProxyT

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_ValueProxy<T> : IGH_ValueProxy

Type Parameters

T
The type of this implementation

The GH_ValueProxyT type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyIsValid
Top
Methods
  NameDescription
Public methodDuplicate
Public methodDuplicate_T
Public methodFromString
Performs the String->Value parsing. The default implementation always returns False.
Public methodMutateString
Public methodToString
Performs a default ToString operation on the local value. If the value is Nothing, an empty String is returned.
(Overrides ObjectToString.)
Top
Fields
See Also