Click or drag to resize

Validation3dT Delegate

Delegate to be used during advanced customized searches.

Namespace:  Grasshopper.Kernel.Geometry.SpatialTrees
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public delegate bool Validation3d<T>(
	T element,
	int globalIndex,
	Node3d<T> node
)

Parameters

element
Type: T
Potential hit.
globalIndex
Type: SystemInt32
Index of item in global list.
node
Type: Grasshopper.Kernel.Geometry.SpatialTreesNode3dT
Node containing the element.

Type Parameters

T
Element type.

Return Value

Type: Boolean
True if item can be included in the search, false if not.
See Also