Click or drag to resize

IGH_EventConsumer Interface

Implement this interface if you want to inter-operate with a GH_EventServer.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_EventConsumer

The IGH_EventConsumer type exposes the following members.

Methods
  NameDescription
Public methodIsRelevantEvent
Whenever a new object event is handled, this function will be called to determine whether it will cause an update.
Public methodPartialExpiration
This method will be called by the GH_CustomEventServer to indicate one or more interesting object events can now be processed.
Public methodTotalExpiration
This method will be called by the GH_CustomEventServer to indicate all interesting object events can now be processed.
Top
See Also