Click or drag to resize

IGH_PreviewObject Interface

All IGH_DocumentObjects that wish to participate in Viewport redraws must implement this interface.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_PreviewObject

The IGH_PreviewObject type exposes the following members.

Properties
  NameDescription
Public propertyClippingBox
Gets the clipping box for this object. The clipping box is typically the union of the boundingboxes of all the geometry that is drawn by this object.
Public propertyHidden
Gets or sets a value indicating whether or not this object is currently drawing preview flags.
Public propertyIsPreviewCapable
Gets a value indicating whether or not this object (in its current state) can draw geometric previews at all.
Top
Methods
  NameDescription
Public methodDrawViewportMeshes
Implement this function to draw all shaded meshes. If the viewport does not support shading, this function will not be called.
Public methodDrawViewportWires
Implement this function to draw all wire and point geometry previews.
Top
See Also