Click or drag to resize

IGH_StateAwareObject Interface

Implement this interface if you want to be included in state saving/loading.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_StateAwareObject

The IGH_StateAwareObject type exposes the following members.

Methods
  NameDescription
Public methodLoadState
Override this function to load your state data. DO NOT START A NEW SOLUTION. This will be handled by the state manager.
Public methodSaveState
Override this function to store your state data. You have to return a deserializable string.
Top
See Also