Click or drag to resize

IGH_UserPromptAware Interface

Implement this interface in your IGH_Param if you want to allow users to set data either through the menu or by double clicking.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_UserPromptAware

The IGH_UserPromptAware type exposes the following members.

Methods
  NameDescription
Public methodPromptMenuMultipleItems
Create a menu item that will be inserted into the Parameter context menu for getting multiple values.
Public methodPromptMenuSingleItem
Create a menu item that will be inserted into the Parameter context menu for getting single values.
Public methodPromptMultipleItems
Get multiple items from the user.
Public methodPromptSingleItem
Get a single item from the user.
Top
See Also