GH_GeometricGooWrapper Class |
Namespace: Grasshopper.Kernel.Types
The GH_GeometricGooWrapper type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_GeometricGooWrapper | Initializes a new instance of the GH_GeometricGooWrapper class |
![]() | GH_GeometricGooWrapper(IGH_GeometricGoo) | Initializes a new instance of the GH_GeometricGooWrapper class |
Name | Description | |
---|---|---|
![]() | Boundingbox | |
![]() | InternalGoo | |
![]() | IsGeometryLoaded | |
![]() | IsReferencedGeometry | |
![]() | IsValid | |
![]() | IsValidWhyNot | |
![]() | ReferenceID | |
![]() | TypeDescription | |
![]() | TypeName |
Name | Description | |
---|---|---|
![]() | CastFrom | |
![]() | CastToT | |
![]() | ClearCaches | |
![]() | Duplicate | |
![]() | DuplicateGeometry | |
![]() | EmitProxy | |
![]() | GetBoundingBox | |
![]() | LoadGeometry | |
![]() | LoadGeometry(RhinoDoc) | |
![]() | Morph | |
![]() | Read | |
![]() | ScriptVariable |
This function will be called when the local IGH_Goo instance
disapears into a user Script. This would be an excellent place to
cast your IGH_Goo type to a simple data type.
|
![]() | ToString | (Overrides ObjectToString.) |
![]() | Transform | |
![]() | Write |