Click or drag to resize

AnnotationDateTimeFormat Class

Represents a Date Time format.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooString
    Grasshopper.Kernel.TypesGH_String
      Grasshopper.Rhinoceros.AnnotationsAnnotationDateTimeFormat

Namespace:  Grasshopper.Rhinoceros.Annotations
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class AnnotationDateTimeFormat : GH_String, 
	IEquatable<AnnotationDateTimeFormat>

The AnnotationDateTimeFormat type exposes the following members.

Constructors
  NameDescription
Public methodAnnotationDateTimeFormat
Initializes a new instance of the AnnotationDateTimeFormat class
Public methodAnnotationDateTimeFormat(GH_String)
Initializes a new instance of the AnnotationDateTimeFormat class
Public methodAnnotationDateTimeFormat(String)
Initializes a new instance of the AnnotationDateTimeFormat class
Top
Properties
  NameDescription
Public propertyDisplayName
Top
Methods
  NameDescription
Public methodCastFrom (Overrides GH_StringCastFrom(Object).)
Public methodDuplicate (Overrides GH_StringDuplicate.)
Public methodEquals(AnnotationDateTimeFormat)
Public methodEquals(Object) (Overrides ObjectEquals(Object).)
Public methodGetHashCode (Overrides ObjectGetHashCode.)
Top
See Also