Click or drag to resize

GH_GooT Class

Base class for IGH_Goo implementation. Takes care of some default behaviour.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooT
    More...

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_Goo<T> : IGH_Goo

Type Parameters

T

The GH_GooT type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyIsValid
Gets a value indicating whether or not the current value is valid.
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
Public propertyTypeDescription
Gets a description of the type of the implementation.
Public propertyTypeName
Gets the name of the type of the implementation.
Public propertyValue
Gets or sets the internal data.
Top
Methods
  NameDescription
Public methodCastFrom
Attempt a cast from generic data.
Public methodCastToQ
Attempt a cast to type Q.
Public methodDuplicate
Make a complete duplicate of this instance. No shallow copies.
Public methodEmitProxy
Create a new proxy for this instance. Return Null if this class does not support proxies.
Public methodRead
Default behaviour is to return True.
Public methodScriptVariable
This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type.
Public methodToString
Creates a string description of the current instance value.
(Overrides ObjectToString.)
Public methodWrite
Default behaviour is to return True.
Top
Fields
  NameDescription
Protected fieldm_value
Top
Remarks
Feel free to implement IGH_Goo directly though.
See Also
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooT
    Grasshopper.Kernel.TypesGH_Boolean
    Grasshopper.Kernel.TypesGH_Colour
    Grasshopper.Kernel.TypesGH_ComplexNumber
    Grasshopper.Kernel.TypesGH_Culture
    Grasshopper.Kernel.TypesGH_GeometricGooT
    Grasshopper.Kernel.TypesGH_Guid
    Grasshopper.Kernel.TypesGH_Integer
    Grasshopper.Kernel.TypesGH_Interval
    Grasshopper.Kernel.TypesGH_Interval2D
    Grasshopper.Kernel.TypesGH_Material
    Grasshopper.Kernel.TypesGH_Matrix
    Grasshopper.Kernel.TypesGH_MeshFace
    Grasshopper.Kernel.TypesGH_MeshingParameters
    Grasshopper.Kernel.TypesGH_Number
    Grasshopper.Kernel.TypesGH_ObjectWrapper
    Grasshopper.Kernel.TypesGH_String
    Grasshopper.Kernel.TypesGH_StructurePath
    Grasshopper.Kernel.TypesGH_Time
    Grasshopper.Kernel.TypesGH_Transform
    Grasshopper.Kernel.TypesGH_Vector